Page 175 of 176 FirstFirst ... 75125165173174175176 LastLast
Results 1,741 to 1,750 of 1754

Thread: What did Chief do to his Mazdas today?

  1. #1741
    Now with pictures, but not for you! chiefmg's Avatar
    Join Date
    Dec 2007
    Location
    N KY
    Miata: Went to a local C&C yesterday. I still love this car.

    '81 RX-7, '00 Miata SE, '06 RX-8 (wife's), '15 CX-5 GT AWD.

  2. #1742
    Now with pictures, but not for you! chiefmg's Avatar
    Join Date
    Dec 2007
    Location
    N KY
    Miata: Finally got around to adding some lock nuts to the muffler hanger I added. When I looked underneath I found one nut had disappeared yet again. I was thinking about using Nyloc nuts but someone pointed out the nylon might melt if the temperature of the hanger got high enough. Solution was some all-metal lock nuts courtesy of Ace.



    Put those on to back up the regular nuts I had on there, shouldn't be any more issues with that.

    I decided to pull the MS harness connections to see if there were any loose wires that might be causing the intermittent CEL. Didn't find anything abnormal, however when I was putting everything back together the power wire to the wideband pulled out of the StaKon. Fixed that with a new connector. Cleaned up my wire routing a little bit too, since I was already contorted it was a good time to do that. I'm getting too old for crawling underneath a dash. Have to do some driving to see if I took care of the CEL once and for all.
    '81 RX-7, '00 Miata SE, '06 RX-8 (wife's), '15 CX-5 GT AWD.

  3. #1743
    Now with pictures, but not for you! chiefmg's Avatar
    Join Date
    Dec 2007
    Location
    N KY
    Miata: Been a while since I updated this. Got home mid-July and looked into some things trying to figure out the intermittent CEL I have been getting. Some research showed I never connected the white wire for the wideband gauge lighting to ground as instructions direct so I did that. While I was in there I slotted the upper hole for my Megasquirt mounting bracket to make it easier to get the thing in and out. I also pulled the connection harness between the factory harness and the MS to look for any problems with it but nothing presented.

    A few days later I changed the supercharger oil. I had noted some leakage past the snout seal so wanted to check on how much was left. Strangely enough I got 4 ounces out of it which is what is called for. Combined with the fact that I only had 2 ounces remaining in the bottle the rebuilder sent me, the logical conclusion is that the rebuilder overfilled it. I used some AC/Delco oil I got off Amazon. I had also purchased a replacement ‘charger mounting bracket from FFS to see if there was any difference between it and the original BRP bracket. There was not so I went back to the original bracket. I was able to remove one of the washers I used for a shim to space the ‘charger snout away from the crank.

    I did an oil/filter change, adjusted the center butterfly brace part to give me some more clearance, and adjusted my steering wheel after trying different things to clear the blinking airbag light (unsuccessfully). Thanks to some things coming together I was headed for MATG again this year.

  4. #1744
    Now with pictures, but not for you! chiefmg's Avatar
    Join Date
    Dec 2007
    Location
    N KY
    She gave me some trouble on the way down, again with an intermittent CEL and one time with the battery light coming on after which I was unable to restart her for about 15 minutes (had stopped at a rest area). Other than that she ran pretty well the whole time there. I did more driving this year than last, met new people and reconnected with old friends.






    While there I was talking to a member from another forum and he suggested looking into leaks from the FO injector seals as a cause for my fuel smell under boost. After considering this and other possible problems with the fuel system, when I got home I ordered a new fuel pulsation damper along with some injector O-rings/seals. I did see some leakage from the ‘charger drain/fill plug so ordered a new one of those as well.
    '81 RX-7, '00 Miata SE, '06 RX-8 (wife's), '15 CX-5 GT AWD.

  5. #1745
    Now with pictures, but not for you! chiefmg's Avatar
    Join Date
    Dec 2007
    Location
    N KY
    I was driving to the store one night after getting home and heard a clicking noise that sounded like it was coming from the stereo. After some on-the-fly troubleshooting I realized it was happening when I used the clutch. Suspicion was it was the green plug for the upper clutch switch. When I got home I looked and there the old one was in pieces on the floor. Luckily I had an extra from when I was trying to fix my cruise control problem so got that fixed quickly.

    '81 RX-7, '00 Miata SE, '06 RX-8 (wife's), '15 CX-5 GT AWD.

  6. #1746
    Now with pictures, but not for you! chiefmg's Avatar
    Join Date
    Dec 2007
    Location
    N KY
    All my parts came in today so I set about pulling the supercharger and upper intake manifold. Got about 3 ounces of oil out of the supercharger so that needed doing. There was some oil residue in the charge air piping, not sure if this was a result of my using different oil or not.

    When I removed the upper intake manifold and the injectors, I saw signs there was leakage past the O-rings on the #1 and 4 cylinders. Pulling the injector spacers showed the O-rings were collapsed:









    I was given two sets of O-rings after sending the injectors out for checking, I used the larger set as they seemed to fit tightly but it looks like they were too tight. No way O-rings should have a flat cross-section after just a couple of years. I cleaned everything up and installed new O-rings and head seals using the lubricant provided. Installed the new fuel pulsation damper as well, just in case it was a contributing factor.



    The results on a quick test drive? No more overpowering fuel smell under boost. Have to do some more driving to see if that also took care of the CEL.
    Last edited by chiefmg; 08-14-2019 at 10:51 PM.
    '81 RX-7, '00 Miata SE, '06 RX-8 (wife's), '15 CX-5 GT AWD.

  7. #1747
    Now with pictures, but not for you! chiefmg's Avatar
    Join Date
    Dec 2007
    Location
    N KY
    Miata: about a week and a half ago I took a drive to visit a friend from several forums. After a nice visit I drove home with a part in my possession. Good thing too as the one I was using was on its last legs. What might that be? One radiator fan shroud. First, a picture of the Lexan one I removed:

    i have

    You can see two of the attachment points had broken off. After some aligning and drilling of new holes for my fans, the installed shroud looks like this:



    It is a Mishimoto shroud, fits great and now I don't have to worry about fatigue failure (at least as much) of the material used.

    I have had gas smell under boost again, but the injectors O-rings are not leaking so this should (hopefully anyway) be down to a tuning issue. Heading back to work end of the weekend so that will have to wait for my next time home.

  8. #1748
    Now with pictures, but not for you! chiefmg's Avatar
    Join Date
    Dec 2007
    Location
    N KY
    Miata: Finally back home. Picked up my second set of wheels and brought them home yesterday (the ones with the S-drives, my winter tires). Pulled the alternator this morning and dropped it off at a rebuilder. The place has been there for 48 years, I used them for another car's alternator maybe 30 years ago. Kind of weird in this day and age to see that sort of longevity in a business. I did some research while I was away and the symptoms I have experienced points to the alternator going bad. It will be tested, although that may not be a good indicator of the problem since it only seems to crop up after several hours driving (presumably heat related).
    '81 RX-7, '00 Miata SE, '06 RX-8 (wife's), '15 CX-5 GT AWD.

  9. #1749
    Now with pictures, but not for you! chiefmg's Avatar
    Join Date
    Dec 2007
    Location
    N KY
    Miata: Jet lag has hit me hard the past few days so I'm a bit behind. Saturday morning I went to see a guy about a set of footwell lights. He sells these on Miata.net and is local so I figured why not? It's a very nice kit so if you think you can use more light in your cabin, get a set:





    While I was on my way home I got a call from the folks who were looking at my alternator saying it was done, so I stopped in and picked it up. They said everything looked fine inside. It didn't appear the unit had been opened but it only cost me $10 so I just figured they ran a diagnostic.


    Sunday morning I was out in the garage to install the alternator. Completely removed the splash guard then tried putting the alternator on with no success. Got back out from under the car and looked at the thing, it appeared that the sections were not aligned properly (see through bolt in this picture):





    As you can see it looked like the bolt was crooked so I just figured the bolt holes were off a tad. I corrected that and then tried to put it in again. No luck the second time so came back out from under and had another look. That was when I noticed the threaded hole for the pivot bolt was not lined up with the hole on the back side. Whoever assembled the alternator put the two parts together 180 degrees off. After some choice words i removed the four through bolts and then tapped the parts into proper alignment. Once that was done it went in right away. I was pissed so didn't take any pictures of the bad assembly.


    After doing some cleaning on the bottom of the engine below the supercharger and putting the splash guard back on I put the other wheels with the S-drives on. The battery was dead since the car wasn't started while I was gone so that went on the charger. Today I finally got her started and went for a drive. It was short but sweet.

  10. #1750
    Now with pictures, but not for you! chiefmg's Avatar
    Join Date
    Dec 2007
    Location
    N KY
    Miata: Went to take a drive yesterday but the battery was pretty flat. Looks like I need to do some testing for a parasitic drain.


    These showed up today:



    Sport brake calipers. After talking to a few folks I figured this was my best and cheapest route to larger brakes without having to sacrifice my wheels. None of the breaker vendors I spoke to had any on hand so I just went with the easy button and ordered overhauled calipers from Rock Auto. Spent a bit extra and got the coated ones. Still need to order a master cylinder and decide on the rotors and pads I want to run.
    '81 RX-7, '00 Miata SE, '06 RX-8 (wife's), '15 CX-5 GT AWD.

Page 175 of 176 FirstFirst ... 75125165173174175176 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •