Page 127 of 178 FirstFirst ... 2777117125126127128129137177 ... LastLast
Results 1,261 to 1,270 of 1772

Thread: What did Chief do to his Mazdas today?

  1. #1261
    (╯°□°)╯︵ ┻━┻) roy obanion's Avatar
    Join Date
    Aug 2008
    Location
    St. Louis, MO
    And who knows when they would come...


    roadster love.

    "Adding power makes you faster on the straights. Adding lightness makes you faster everywhere."

  2. #1262
    Now with pictures, but not for you! chiefmg's Avatar
    Join Date
    Dec 2007
    Location
    N KY
    I know, right? Last time I ordered something from them I had to call several times to get it. Not sure why their service went downhill.

    Three hours and fifteen minutes to pull the head off the Miata. Looks fine with no apparent warpage. The only thing I can think of is the slightly uneven tightening I did due to that little bit of wiring that got trapped at the rear. If that was it, then it means the MLS gaskets can absolutely not be compressed more than once. I'm going to try cleaning the head up with some aluminum polish I saw at Ace, ordering the gasket in the morning.

    Helpful tip, an easy way to remove hard-to-reach washers is to use a magnet. My fingers are somewhat long and slender, but just won't reach into the head very well.

  3. #1263
    Now with pictures, but not for you! chiefmg's Avatar
    Join Date
    Dec 2007
    Location
    N KY
    Got the head gasket ordered, it will be here on Wednesday. Cleaned up the head and block surfaces, due for a root canal tomorrow so I doubt I'll feel like doing much. Replaced the studs/nuts holding the reroute spacer on with socket head cap screws, I couldn't get the one nut tight enough to make me happy due to the machining which restricted access to it. I had put the bottom nuts for the intake manifold on the head so they wouldn't get lost, as I was cleaned it up I noticed one was missing. Looked all over for the damn thing and couldn't find it, right before I came in I moved the head slightly and heard a clink. There it was! Still have no idea where it was hiding.

  4. #1264
    Now with pictures, but not for you! chiefmg's Avatar
    Join Date
    Dec 2007
    Location
    N KY
    Pictures of the head before/after cleaning:



  5. #1265
    Now with pictures, but not for you! chiefmg's Avatar
    Join Date
    Dec 2007
    Location
    N KY
    Installed the GROM Audio adapter in the 8, that thing is nice. I also bought their Bluetooth dongle but it isn't working so I need to do some research to see if an app requires downloading or if it's something else.

  6. #1266
    Now with pictures, but not for you! chiefmg's Avatar
    Join Date
    Dec 2007
    Location
    N KY
    Finally got the replacement springs put on the BC coilovers for the 8, it's amazing how much easier a vise can make some jobs.

    Got the Miata mostly back together, just need to get some more coolant and install the belly pan and cowl cover. Then we'll see if she fires up.

  7. #1267
    Now with pictures, but not for you! chiefmg's Avatar
    Join Date
    Dec 2007
    Location
    N KY
    Got the Miata all back together. Went out with the wife last night, car was idling high so this morning I checked my rerouting of the throttle cable. I moved it to a slightly different position which seemed like it would improve things. Went to start the car before heading to lunch, crank, crank, crank, start and immediately to redline. Shut her down and checked, the throttle cable had jumped off the bellcrank. Took a look after lunch, I didn't get the holding bracket for the throttle cable oriented correctly which is what caused the problem. FYI, that bracket must be parallel to the ground or slightly higher, otherwise because the throttle body is at an angle the cable will not align properly and will come off the bellcrank. This is a bad thing.

    When I got that all back together I noticed there wasn't any slack in the cable, causing the throttle to be held open. A couple of washers on the bolt behind the cable bracket to move it closer to the throttle body fixed that. Took a test drive and all those problems are now solved.
    '81 RX-7, '00 Miata SE, '06 RX-8 (wife's), '15 CX-5 GT AWD.

  8. #1268
    Now with pictures, but not for you! chiefmg's Avatar
    Join Date
    Dec 2007
    Location
    N KY
    It was an 8 day today, well, after I got done installing the new light fixtures in the master bath.

    Swapped out the front coilovers (back to the BC Racing ones) and changed the oil/filter. Had to stop there for the day as Robyn is taking me out tonight. Tomorrow is going to be very busy...

  9. #1269
    Now with pictures, but not for you! chiefmg's Avatar
    Join Date
    Dec 2007
    Location
    N KY
    Changed oil/filter and cleaned the MAF on the Speed. Replaced the spark plugs with the same Denso ITV22s. I gapped them at 0.030, old ones that came out were around 0.038 so just a tad worn. Also swapped out the spring in the BPV for the red one (stiffest) to see if that clears up my occasional flutter. I did notice some pitting at the top of the piston which may be a factor, I'll have to see if I can just get a replacement part instead of a whole new valve.

  10. #1270
    Now with pictures, but not for you! chiefmg's Avatar
    Join Date
    Dec 2007
    Location
    N KY
    Busy day today. Supervised my stepson in changing the oil/filter on the Cabrio after the work on the Speed. Looking at the BC coilovers on the front of the 8, they were too low. I adjusted the rears (increased the length about 25mm) before installing them. Once they were done I went back to the fronts and adjusted them, that only took me about 30 minutes for both sides. As it sits right now it's a good ride height, I'll see how it looks after some actual driving on it (yes, I preloaded the bushings before tightening the fasteners).

Page 127 of 178 FirstFirst ... 2777117125126127128129137177 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •