Results 1 to 2 of 2

Thread: Help - hold light flashing :(

  1. #1

    Help - hold light flashing :(

    Hi all. I've had a ton of Mazda's over the years so I thought I better sign up. I've been getting the run around with our little hack I use for getting back and forward around town. It's a 1998 BJ5W Mazda Familia (Japan import) with the 1500cc variable valve timing engine.

    All a sudden, from start it seems to want to go from 1st to 3rd, when it does this the HOLD light flashes, also it has a red line of around 7500rpm but sits on about 4000rpm at 100kph so I'm guessing there's another half gear that it's missing at the top. Once it goes from 1st to 3rd it also stays locked in 3rd whatever speed I do, even when I come to a stop it takes off in 3rd. If I'm starting on a hill, I have to stop the engine, stop and restart and set off again or it will take ages to get up to 50kph. I've taken it to be diagnosed and they gave a fault code of P0730 (incorrect gear ratio) but the auto trans specialist wants to remove the transmission and pull it apart to fully inspect and repair/recondition the whole thing for around $3000-$4000 NZD - when the car is only worth around half this I am reluctant to do so, especially when I can get a 2nd hand transmission for $500 + labour to install!!!

    As a last resort we will head in the direction of the 2nd hand transmission, but just wondering if anyone here has had the same issues and what direction they took or had to take before I go through that whole drama!!!

    Thanks in advance.
    Attached Images

  2. #2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •